• Benvenuti su RaspberryItaly!
Benvenuto ospite! Login Login con Facebook Registrati Login with Facebook


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5

[-]
Tags
in sfarfallamento sul fading omxplayer bianco raspberry out del e

omxplayer e sfarfallamento sul bianco del fading out e in
#1
Ciao, oggi mi sono accorto che se ho dei fade in o fade out sullo sfondo bianco del video si vedono delle righe diagonali tremolanti, effetto flickering, non cambia nulal se uso 25 o 30 fps o se cambio il bitrate da 0.7 a 10mbps.il video è stato generato con ffmpeg usando il codec h264. i comandi -y, -z, -r non aiutano. usando  -r, le slide appaiono molto piu pulite, ma anche il tremolio diagonale (sempre la stessa diagonale e mai orizzontale o verticale) diventa piu definito.
Io ipotizzo che possa dipendere dal codec, ma non so quali codec posso usare con ffmpeg e quali puà leggere omxplayer. spero qualcuno posso illuminarmi. so che omxplayer supporta questi formati: mp4,avi,mkv,mp3,mov,mpg,flv,m4v ma quali sono i codec supportati? qui il file originale in questione:
http://185.24.234.250/ffmpeg-test/vertical-fade-out-1-sec.mp4
e qui come si vede facendo play su raspberry pi 3 model b con gpu:128mb
[url=https://www.baramadori.tk/1.3gpp]https://www.baramadori.tk/1.3gpp
ultima versione di  omxplayer:
Codice:
Build date: Fri, 23 Sep 2016 00:56:49 +0000
       Version   : dfea8c9 [master]
       Repository: https://github.com/popcornmix/omxplayer.git

On raspbian jessie with desktop
Codice:
Release date:2017-07-05
Kernel version:4.9

data about the mp4 file:
`Format : MPEG-4
Format profile : Base Media
Codec ID : isom (isom/iso2/avc1/mp41)
File size : 40.1 MiB
Duration : 48 s 0 ms
Overall bit rate : 7 016 kb/s
Writing application : Lavf57.56.100
Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4
Format settings, CABAC : Yes
Format settings, RefFrames : 4 frames
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 48 s 0 ms
Bit rate : 7 013 kb/s
Nominal bit rate : 10 000 kb/s
Width : 1 080 pixels
Height : 1 920 pixels
Display aspect ratio : 0.563
Frame rate mode : Constant
Frame rate : 25.000 FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.135
Stream size : 40.1 MiB (100%)
Writing library : x264 core 148 r2643 5c65704
Encoding settings : cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex / subme=7 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=3 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=abr / mbtree=1 / bitrate=10000 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00
[color=#000000]
 Metadata:
major_brand : isom
minor_version : 512
compatible_brands: isomiso2avc1mp41
encoder : Lavf57.56.100
Duration: 00:00:48.00, start: 0.000000, bitrate: 7015 kb/s
Stream #0:0(und): Video: h264 (High) (avc1 / 0x31637661), yuv420p, 1080x1920 [SAR 1:1 DAR 9:16], 7013 kb/s, 25 fps, 25 tbr, 12800 tbn, 50 tbc (default)
Metadata:
handler_name : VideoHandler`
Risposta
#2
Ok, risolto, la colpa è di omxplayer che non funziona bene i video creati girati di 90 gradi.
Risposta
#3
Non sono riuscito a vedere i video, ma dalla descrizione credo si tratti semplicemente di effetto moiré, un effetto ottico on questo caso dovuto alla risoluzione.
Risposta
#4
Si, scusa una volto risolto ho tolto i video per risparmiare spazio, si era probabilmente quel problema, grazie!
Risposta
  


Vai al forum:


Navigazione:
Forum con nuovi Post
Forum senza nuovi post
Forum bloccato
Forum Redirect