• Benvenuti su RaspberryItaly!
Benvenuto ospite! Login Login con Facebook Registrati Login with Facebook


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5

[-]
Tags
jessie 09 24 2015 rpirrigate raspbian

[Risolto] 2015-09-24-raspbian-jessie - RPirrigate
#1
Buongiorno

Ho scaricato e installato la nuova e aggiornata "img 2015-09-24-raspbian-jessie", ma quando ho provato ad installare RPirrigate dalla nuova guida messa online da Gabriele Toselli (testata funzionante su "2015-05-05-raspbian-wheezy"), al comando di start del servizio pigpiod e rpirrigate ho ricevuto i seguenti errori:

- Failed to start rpirrigate.service: Unit rpirrigate.service failed to load: No such file or directory.
- Failed to start pigpiod.service: Unit pigpiod.service failed to load: No such file or directory.

Help me.

allego copia dell'installazione.

Grazie per le risposte.


Allegati
.txt   2015-09-24-raspbian-jessie e rpirrigate .txt (Dimensione: 22.73 KB / Download: 10)
Huh  SCossa - carmine  Huh
Risposta
#2
Prova a sostituire le prime righe dei due file init
Invece che bin/sh metti bin/bash

Se no prova ad installare i demoni con update-rc.d... Ora non ricordo esattamente la sintassi magari googla la sintassi e prova Wink


Inviato dal mio iPhone utilizzando Tapatalk
http://bobvann.noip.me
Hai un Raspberry Pi?
(SI)   complimenti, ottima scelta Wink
(NO) compralo al più presto Wink
Risposta
#3
Ciao Bobvann,  ho eseguito la modifica trasformado la prima riga in #!/bin/bash dei file  init.d.erb e pigpiod.erb.
Il risultato però non è cambiato. Ho anche eseguito una nuova installazione da capo ma l'errore (Failed) di cui sopra si ripete.
Scusa la mia ingnoranza ma anche cercando su google non ho compreso bene come installare a mano i demoni.

Ti ringrazio per la risposta.
Huh  SCossa - carmine  Huh
Risposta
#4
# update-rc.d rpirrigate defaults
# update-rc.d pigpiod defaults





Inviato dal mio iPhone utilizzando Tapatalk
http://bobvann.noip.me
Hai un Raspberry Pi?
(SI)   complimenti, ottima scelta Wink
(NO) compralo al più presto Wink
Risposta
#5
(04/11/2015, 08:25)bobvann Ha scritto: # update-rc.d rpirrigate defaults
# update-rc.d pigpiod defaults





Inviato dal mio iPhone utilizzando Tapatalk
Ciao Bobvann grazie, faccio la prova e ti aggiorno.

Inviato dal mio A0001 utilizzando Tapatalk
Huh  SCossa - carmine  Huh
Risposta
#6
Ciao Bobvann, ho eseguito la modifiche, mi dispiace ma lo "Stato del demone rimane Fermo".
Huh  SCossa - carmine  Huh
Risposta
#7
Prova a fare

/etc/init.d/rpirrigate start

E vedi cosa da in output


Inviato dal mio iPhone utilizzando Tapatalk
http://bobvann.noip.me
Hai un Raspberry Pi?
(SI)   complimenti, ottima scelta Wink
(NO) compralo al più presto Wink
Risposta
#8
Ciao, anche dando il comando:
pi@raspberrypi ~ $ sudo /etc/init.d/rpirrigate start
Starting service
Service started
pi@raspberrypi ~ $

Il demone rimane fermo!
Huh  SCossa - carmine  Huh
Risposta
#9
scusa se ci metto un sacco a rispondere ma sono veramente pieno di impegni

prova questo (da root/sudo) poi riavvia il raspi

chsh -s /bin/sh www-data
http://bobvann.noip.me
Hai un Raspberry Pi?
(SI)   complimenti, ottima scelta Wink
(NO) compralo al più presto Wink
Risposta
#10
Ok

Inviato dal mio A0001 utilizzando Tapatalk
Huh  SCossa - carmine  Huh
Risposta
  


Vai al forum:


Navigazione:
Forum con nuovi Post
Forum senza nuovi post
Forum bloccato
Forum Redirect