• Benvenuti su RaspberryItaly!
Benvenuto ospite! Login Login con Facebook Registrati


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5

[-]
Tags
root di login

[Problema] LOGIN DI ROOT
#1
ho un problema,quando voglio connettermi in remoto al Raspberry Pi2 con PuttY, come Root, dopo aver settato tutti i parametri,e dato invio, sulla finestra di login che si apre digito nome utente (che di default e' PI)e poi la password di root che ho impostato su Raspbian,mi da( Access Denied)non mi fa' entrare,preciso che devo entrare da remoto come Root perche' devo creare le cartelle in WinSCP e solo cosi' posso creare le cartelle perche' altrimenti WinSCP non me lo fa' fare. Se qualcuno puo' aiutarmi GRAZIE Rolleyes  Huh
 
Risposta
#2
Entra con l'utente pi e quando sei collegato dai un
Codice:
sudo su

Inviato dal mio m2 note utilizzando Tapatalk
Il mio software non ha mai bugs. Include soltanto funzionalità casuali.


 
Risposta
#3
L'utente pi ha la sua password, l'utente Root ne avrà un'altra.
L'utente pi può comunque lavorare come Root, antepone do "sudo" ai comandi. Oppure, se dai il comando suggerito da GabrieleToselli, ogni comando successivo sarà eseguito come Root.
Sudo = Super User Do
 
Risposta
#4
ok, grazie della risposta,ma dovrei entrare con Putty gia'da utente root altrimenti il programma WinSCP non mi fa' creare le cartelle ni dice che non sono autorizzatocome utente PI, non so se da qualche parte ho letto che di default raspbian non ti autorizza,e alllora bisogna settare raspbian ma non so dove trovare questa configurazione. Oppure se posso creare le cartelle su WinSCP in un altro modo!!Grazie
 
Risposta
#5
Intanto potresti non incaponirti a usare WinSCP, ma qualsiasi altro Client FTP / SFTP (chi ha detto Filezilla?).. Secondo me stai facendo un po' di confusione.. Che c'entra putty con programmi ftp?
Basterebbe dare gli opportuni permessi, probabilmente.
Non è per nulla consigliabile lavorare come utente Root.
Comunque, per entrare con putty già con utente Root, entra come utente Root, non NON pi.
Di default l'utente Root non ha password, puoi impostarne una entrando come pi e poi dando il comando
Codice:
sudo passwd root
E poi uscire e rientrare come root e password scelta
 
Risposta
#6
ho capito, ti ringrazio della spiegazione!
 
Risposta
#7
Scusate ma io e un mio amico abbiamo lo stesso problema.
Da remoto non riesco ad entrare come root, ma solo come pi, da tutti i programmi: putty, kitty, e winscp.
Ora con putty e kitty non c'è problema entro con pi e poi digito "sudo su" e mi va in root, ma con winscp non si può cambiare il login, una volta entrato con "pi".
E non posso creare le cartelle, prima della directory "home/pi" ma solo nella directory "pi".
Se digito solo "su" sia da remoto che da locale mi chiede la password e funziona, ma da remoto il login con root mi dice accesso negato, anche i libri che ho comprato e su internet non mi sono di aiuto, potete aiutarmi voi? Grazie in anticipo.
 
Risposta
#8
Per abilitare il login come root:

Enable root logins using ssh in Debian 8.0 (Jessie)
To do this you need to edit the ssh config file ‘/etc/ssh/sshd_config/sshd_config’ as root:
nano /etc/ssh/sshd_config
Then find the entry in the Authentication section of the file that says ‘PermitRootLogin’ and change ‘without-password’ to ‘yes’.
# Authentication:
LoginGraceTime 120
#PermitRootLogin without-password
PermitRootLogin yes
StrictModes yes

Entrando come root è necessario, come solito, fare attenzione

Edit by Zzed: essendo questo un forum in italiano, dedicato all' utenza italiana, mi permetto di tradurre :
Citazione: Abilitare il login di Root usando SSH su Debian 8.0 (Jessie)
Per farlo è necessario editare il file di configurazione di ssh, come root ‘/etc/ssh/sshd_config/sshd_config’:
Codice:
nano /etc/ssh/sshd_config

Ora cerca, nella sezione Authentication del file, la voce ‘PermitRootLogin’, e modifica ‘without-password’ a ‘yes’.
Citazione:
# Authentication:
LoginGraceTime 120
#PermitRootLogin without-password
PermitRootLogin yes
StrictModes yes
 
Risposta
#9
Grazie sei un genio, sei stato anche rapido e dettagliato, mi stavo scoraggiando, ora posso andare avanti con il corso.
 
Risposta
  


Vai al forum:


Navigazione:
Forum con nuovi Post
Forum senza nuovi post
Forum bloccato
Forum Redirect