• Benvenuti su RaspberryItaly!
Benvenuto ospite! Login Login con Facebook Registrati Login with Facebook


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5

[-]
Tags
off gpio risolto state problema on

[RISOLTO] Problema GPIO state ON OFF
#1
Ciao, ho installato con successo RPirrigate su raspbian-jessie. Ho connesso una scheda 8 relay per pilotare le 7 zone del mio giardino.
Purtroppo nonostatnte all'avvio dei servizi i GPIO sono in stato LOW, quando o per programmazione o per forzatura manuale cambio per la prima volta lo stato in ON di un qualsivoglia GPIO, ogni successiva azione di irrigazione/stop risulta essere invertita, ossia quando il sistema dovrebbe irrigare il valore di GPIO è LOW, quando a riposo passa su HIGH.
Questo vale per ogni GPIO che ho testato.
Ho applicato anche l'ultima modifica che rimuove PIGPIO.
Spero di essermi spiegato. Da cosa può dipendere?
Risposta
#2
Forse dalla scheda relè. Potrebbe esserci un ponticello per il funzionamento invertito. Ha anche dei led di stato, per vedere quali relè sono eccitati?
Risposta
#3
(11/04/2016, 20:36)Zzed Ha scritto: Forse dalla scheda relè. Potrebbe esserci un ponticello per il funzionamento invertito. Ha anche dei led di stato, per vedere quali relè sono eccitati?

OPS, guardando il programma mi sono accorto che bobvan ha previsto tutto. Un bel parametro su GPIOClass.py risolve il problema.
Scusate, la prossima volta controllerò meglio!
Risposta
  


Vai al forum:


Navigazione:
Forum con nuovi Post
Forum senza nuovi post
Forum bloccato
Forum Redirect