• Benvenuti su RaspberryItaly!
Benvenuto ospite! Login Login con Facebook Registrati Login with Facebook


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5

[-]
Tags
prima bug irrigazione

[Problema] Bug prima irrigazione
#1
Mi sono accorto che è impossibile programmare un'irrigazione a partire dallo stesso giorno. Mi spiego meglio.
In questo momento è l'1 maggio 2016, ore 13:00 (confermato anche dal system time nella dashboard di RPirrigate) e voglio irrigare ogni giorno alle 14:00. Riempio il form come da prima immagine,do invio, e mi aspetto che l'irrigazione parta dopo 1 ora, ma il risultato è ciò che si vede nella seconda, e cioè la prossima irrigazione partirà DOMANI alle 14:00 (dopo 25 ore) invece che oggi.
Sbaglio a fare qualcosa o è un vero bug?


Allegati Anteprime
       
Ciao
Adriano Arcadipane
Risposta
#2
(01/05/2016, 16:52)neway Ha scritto: Mi sono accorto che è impossibile programmare un'irrigazione a partire dallo stesso giorno. Mi spiego meglio.
In questo momento è l'1 maggio 2016, ore 13:00 (confermato anche dal system time nella dashboard di RPirrigate) e voglio irrigare ogni giorno alle 14:00. Riempio il form come da prima immagine,do invio, e mi aspetto che l'irrigazione parta dopo 1 ora, ma il risultato è ciò che si vede nella seconda, e cioè la prossima irrigazione partirà DOMANI alle 14:00 (dopo 25 ore) invece che oggi.
Sbaglio a fare qualcosa o è un vero bug?

Ciao non penso che sia un bug, in quanto se vuoi annaffiare lo stesso giorno, devi impostare il valore settimana e giorni a 0, quindi il sistema automaticamente imposta il giorno corrente. Prova a fare cosi e vedrai che funziona.
------------------------------------------------
Il mio sito collegato al Rasp con WebCam Meteo
www.romaestpdn.altervista.org
Risposta
#3
No. Per irrigare ogni giorno è corretto inserire 0 settimane, 1 giorno. Il problema che riscontri non riesco a riprodurlo. Ho appena creato una irrigazione ogni 0/1 a partire da oggi alle 17.15 e me la segna oggi[Immagine: 1f1c29bed7ea66b4763a3e6c2ef80d59.jpg]


Inviato dal mio iPad utilizzando Tapatalk
http://bobvann.noip.me
Hai un Raspberry Pi?
(SI)   complimenti, ottima scelta Wink
(NO) compralo al più presto Wink
Risposta
#4
(08/05/2016, 16:12)bobvann Ha scritto: No. Per irrigare ogni giorno è corretto inserire 0 settimane, 1 giorno. Il problema che riscontri non riesco a riprodurlo. Ho appena creato una irrigazione ogni 0/1 a partire da oggi alle 17.15 e me la segna oggi[Immagine: 1f1c29bed7ea66b4763a3e6c2ef80d59.jpg]


Inviato dal mio iPad utilizzando Tapatalk


Anche a me dava lo stesso problema se impostavo 0 settimane e giorno 1. Invece se imposto tutto a 0 partiva all'orario che impostavo nello stesso giorno. 
------------------------------------------------
Il mio sito collegato al Rasp con WebCam Meteo
www.romaestpdn.altervista.org
Risposta
#5
Ma poi i giorni successivi funziona? Io so come funziona (l'ho sviluppato io) e non dovrebbe funzionare con 0 giormi


Inviato dal mio iPad utilizzando Tapatalk
http://bobvann.noip.me
Hai un Raspberry Pi?
(SI)   complimenti, ottima scelta Wink
(NO) compralo al più presto Wink
Risposta
#6
(08/05/2016, 17:26)bobvann Ha scritto: Ma poi i giorni successivi funziona? Io so come funziona (l'ho sviluppato io) e non dovrebbe funzionare con 0 giormi


Inviato dal mio iPad utilizzando Tapatalk


Ci mancherebbe nessuno vuole mettere in dubbio quello che tu dici, visto che sei colui che ha sviluppato questo stupendo sistema, però anche a me si comporta nello stesso modo. Se devo irrigare fra 10 minuti devo impostare tutto a 0 altrimenti non funziona. No nei giorni successivi teoricamente non dovrebbe funzionare visto che è settato a 0 giorni, però se voglio irrigare questa sera alle 20.00 devo impostare tutto a zero. 
------------------------------------------------
Il mio sito collegato al Rasp con WebCam Meteo
www.romaestpdn.altervista.org
Risposta
#7
io ho fatto una prova questo pomeriggio con 0 giorni. è partito, e si è fermato. dopo 1 minuto è ripartito..
Risposta
#8
Infatti questo era il mio dubbio, che con 0 non si chiudesse più.

Quindi confermo che c'è un bug, che salta la prima irrigazione in determinati casi...da testare

SCONSIGLIO vivamente di mettere irrigazioni con 0/0...non sono sicuro di come si comporta e non vorrei rimanesse aperta l'acqua


Inviato dal mio iPhone utilizzando Tapatalk
http://bobvann.noip.me
Hai un Raspberry Pi?
(SI)   complimenti, ottima scelta Wink
(NO) compralo al più presto Wink
Risposta
#9
Confermo anch'io che impostando 0/0 fa continuamente ON/OFF.
Aggiungo che ho il Pi2B con raspbian Jessie
Ciao
Adriano Arcadipane
Risposta
#10
Ho investigato un po' di più.
Adesso sono le 11:19 del 14/05/2015. L'orario di sistema del raspberry è corretto.
Se imposto un'irrigazione a 0 settimane 1 giorno per le 18:00 la prossima irrigazione sarà il 15/05/2015. C'è il bug
Se imposto un'irrigazione a 0 settimane 1 giorno per le 20:00 la prossima irrigazione sarà il 14/05/2015. Qui è OK.

Potrebbe essere qualcosa di legato alla time zone o simile?
Ciao
Adriano Arcadipane
Risposta
  


Vai al forum:


Navigazione:
Forum con nuovi Post
Forum senza nuovi post
Forum bloccato
Forum Redirect