• Benvenuti su RaspberryItaly!
Benvenuto ospite! Login Login con Facebook Registrati Login with Facebook


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5

[-]
Tags
funzionamento non risponde di qualche al dopo pi3 raspberry ora ping

Raspberry PI3 , dopo qualche ora di funzionamento ,non risponde al ping.
#1
Ho un raspberry con STRETCH configurato in WIFI con IP statico
in cui è configurato Node-Red , per leggere la temperatura della Cpu  e inviarla su ThingSpeak.

Dopo la prima 'accensione ,posso usare Vnc per collegarmi dal desktop ( W10 ), per controllare il desktop/raspberry senza problemi,
ma il giorno dopo se riprovo a connettermi non ci riesco e anche provando , da desktop con un ping , non riesco a raggiungere il raspberry.

La cosa strana è che il raspberry continua a inviare i dati su ThingSpeak , quindi la connessione WIFI è attiva e il raspberry funziona.

Ho già provato ad aggiornare Stretch con apt-get update/upgrade e messo in off il power management della WIFi

Qualcuno ha già avuto questo problema e/o ha qualche suggerimento ?
Grazie
Risposta
#2
problema simile ...
io ne ho uno in giardino che manda su thingspeak la temperatura esterna. Anche io ho il problema che dopo diverse ore non lo raggiungo più sulla mia rete ma non manda nemmeno i dati a thingspeak per cui credo che si disconnetta dal wifi (d'altra parte è in giardino ...).
Per ovviare ho provato ad aggiungere uno script che (richiamato da cron) ogni tot tempo pinga il router e se non lo trova riavvia il wi-fi ma non sembra aver dato i risultati sperati.
Adesso pensavo di mettere uno script che, sempre richiamato da cron, mi riavvia il raspbery tutte le notti....
Non risolvo il problema ma almeno lo bypasso (spero che la mia esperienza ti possa interessare).
Risposta
#3
A me è successo con il RaspberryPi che fa l'irrigazione, che d'estate, per il gran caldo, il dongle WiFi si "blocchi". Un ora o due dopo il tramonto, torna raggiungibile.
Risposta
#4
(22/06/2018, 11:06)John Ha scritto: problema simile ...
io ne ho uno in giardino che manda su thingspeak la temperatura esterna. Anche io ho il problema che dopo diverse ore non lo raggiungo più sulla mia rete ma non manda nemmeno i dati a thingspeak per cui credo che si disconnetta dal wifi (d'altra parte è in giardino ...).
Per ovviare ho provato ad aggiungere uno script che (richiamato da cron)  ogni tot tempo pinga il router e se non lo trova riavvia il wi-fi ma non sembra aver dato i risultati sperati.
Adesso pensavo di mettere uno script che, sempre richiamato da cron, mi riavvia il raspbery tutte le notti....
Non risolvo il problema ma almeno lo bypasso (spero che la mia esperienza ti possa interessare).

Grazie per la risposta
il tuo caso sembra un problema di Power Management della scheda wifi, prova a verificare
se è OFF con il comando   iwconfig

nel mio caso il raspberry continua a mandare i dati su thingspeak , 
per cui presumo che non sia un porblema di connessione wifi

(22/06/2018, 12:04)Zzed Ha scritto: A me è successo con il RaspberryPi che fa l'irrigazione, che d'estate, per il gran caldo, il dongle WiFi si "blocchi". Un ora o due dopo il tramonto, torna raggiungibile.

Grazie per la risposta
nel mio caso il problema si verifica sia in casa che in giardino.

Quando non riesco a raggiungerlo da remoto , se collego monitor e tastiera , il raspberry funziona e riesco a  navigare in internet con il browser.

Per riabilitare il collegamento da desktop a raspberry è sufficiente fare un ping dal PI3 all' IP del desktop, che ,dopo questa operazione , riprende a funzionare anche il collegamento dal lato desktop -> PI3
Risposta
#5
Si potrebbe fare un programmino che ogni tot pinga il router.
E' un workaround ma potrebbe funzionare ?
Risposta
#6
Ma in ssh va? O hai provato solo VNC?
Risposta
#7
(26/06/2018, 08:58)John Ha scritto: Si potrebbe fare un programmino che ogni tot pinga il router.
E' un workaround  ma potrebbe funzionare ?

Si penso che sia un workaround , 
ma forse come spiegherò in un post successivo
credo di aver risolto il problema

(26/06/2018, 09:17)Zzed Ha scritto: Ma in ssh va? O hai provato solo VNC?


Si ho provato con MobaXterm , senza risultato ...

Forse ho trovato la soluzione al problema ... sono due giorni che riesco a collegarmi dal desktop al PI3, anche il giorno dopo.

Il Pi3 l'ho installato in una stanza in fondo al giardino , dove il segnale wifi di casa arriva debole , per questo motivo avevo comprato un wifi extender. Con  l'extender funzionante a seconda di quale rete prendeva il PI3, sul router wifi Tim , si presentava con un mac diverso. Per questo motivo avevo riservato due ip uno  x ciascun mac address. 
Quando volevo collegarmi da remoto , provavo con uno o l'altro. 

Quando è morto l'extender , e si collegava solo con il wifi del router di casa ,
ho verificato che perdeva la connessione in entrata mentre continuava a trasmettere in uscita.

Cancellando le due reservation sul router wifi e assegnando un  ip fisso , il problema sembra risolto
Risposta
  


Vai al forum:


Navigazione:
Forum con nuovi Post
Forum senza nuovi post
Forum bloccato
Forum Redirect