• Benvenuti su RaspberryItaly!
Benvenuto ospite! Login Login con Facebook Registrati Login with Facebook


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5

[-]
Tags
telecamera rasp installazione pi2

[Problema] installazione telecamera rasp pi2
#1
un saluto a tutti, mi presento: ho 60 anni, pensionato, una discreta conoscenza di windows dal 3.0 al 10, e mi sono imbarcato con il raspberry pi2!
ho preso il necessario per installare il modulo telecamera e leggendo qua e la ho capito di dover installare una cosa chiamata motion-mmal oppure motion-nmal. (?)
in rete ho trovato il programma e l'ho scaricato ma quando lo scompatto mi da questo messaggo:

pi@raspberry / $ tar zxvf motion-mmal-lowflyerUK-20151114.tar.gz
motion
tar: motion: funzione "open" non riuscita: permesso negato
motion-mmalcam-both.conf
tar: motion-mmalcam-both.conf: funzione "open" non riuscita: permesso negato
tar: uscita con stato di fallimento in base agli errori presedenti

poi con il comando ls -a trovo
.      lib                                            opt                    srv
..     lost+found                                     proc                   sys
bin    media                                          root                   tmp
boot   mnt                                            run                    usr
dev    motion-mmal-lowflyerUK-20151114.tar.gz         sbin                   var
rtc    motion-nmal-lowflyerUK-20151114.tar.gz         selinux
home   motion-nmal.tar.gz                             speedtest.cli

sto usando un rasp pi2, ho installato tightvncserver sul pi2 e uso vnc viewer sul pc e mi collego tramite wifi.
non ho trovato sul web una soluzione per cui, ultima ratio, mi rivolgo a voi .....

un grande grazie a chi vorra' perdere del tempo per rispondermi

franco

ps: immagine in allegato
Risposta
#2
Intanto, su Linux, non è come su Windows. I programmi non devi andare a cercarli in rete, scaricarli, scompattare e installarli a mano.
Funziona un po' come su Android o iOs: c'è un repository in cui ci sono i programmi già compilati per la tua versione di Linux, da cui attingere.
Quindi per installare motion basta scrivere nel terminale
Codice:
sudo apt-get install motion
.
Devi cambiare proprio mentalità
Prima però dovresti abilitare l'ingresso per la camera tramite l'apposita voce in raspi-config :
Codice:
sudo raspi-config

Guarda qui altre info
Ciao
Risposta
#3
@zzed
grazie per la disponibilità
la camera e' abilitata
ho letto che esiste una versione di motion (motion-mmal) specifica per il modulo telecamera e l'ho scaricata tramite il comando apt-get
alla fine sono riuscito a scompattarla con privilegi di amministratore (sudo su) ma non so bene dove ....
ora vorrei far partire il programma ma non so come .....
e poi connettermi al rasp
ciao
Risposta
#4
Se sei entrato come root (con sudo su) la cartella dovrebbe essere la cartella in cui eri quando hai lanciato il comando. Se no guarda in /root

Se no ancora avvialo scrivendo semplicemente il nome del pacchetto che hai installato.
Ciao Smile

Inviato dal mio m2 note utilizzando Tapatalk
Il mio software non ha mai bugs. Include soltanto funzionalità casuali.


Risposta
#5
@GabrieleToselli

grazie per l'interessamento. nel frattempo ho trovato questa guida che mi sembrava buona (ed anche il modo di fare copia incolla da windows a rasp!) http://www.instructables.com/id/Raspberr.../?ALLSTEPS e dopo aver cancellato e disinstallato un po' di roba l'ho seguita passo passo fino alla configurazione di motion dove ho cambiato solo #start in daemon da off ad on come puoi vedere qui sotto
############################################################
# Daemon
############################################################

# Start in daemon (background) mode and release terminal (default: off)
daemon on

# File to store the process ID, also called pid file. (default: not defined)
process_id_file /var/run/motion/motion.pid

poi ho fatto un reboot ma ...... collegandomi al rasp con la porta 8081 ( secondo il file config e' qui che mi esce lo streaming) ricevo un messaggio di errore dal browser (firefox) di connessione non riuscita ..... e sono fermo di nuovo!!!

qualche idea?
Risposta
#6
Hai seguito completamente la guida?
Prova ad avviare manualmente motion e a riprovare.
Nel caso puoi vedere se la porta 8080 è in ascolto....
Digita
Codice:
netstat -a
Questo è il mio:
Codice:
root@Server01-rpi:~# netstat -a
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State
tcp        0      0 localhost:9050          *:*                     LISTEN
tcp        0      0 *:microsoft-ds          *:*                     LISTEN
tcp        0      0 *:9091                  *:*                     LISTEN
tcp        0      0 *:8200                  *:*                     LISTEN
tcp        0      0 *:4200                  *:*                     LISTEN
tcp        0      0 localhost:6665          *:*                     LISTEN
tcp        0      0 localhost:6666          *:*                     LISTEN
tcp        0      0 localhost:ircd          *:*                     LISTEN
tcp        0      0 *:10443                 *:*                     LISTEN
tcp        0      0 *:netbios-ssn           *:*                     LISTEN
tcp        0      0 localhost:6668          *:*                     LISTEN
tcp        0      0 localhost:6669          *:*                     LISTEN
tcp        0      0 *:5678                  *:*                     LISTEN
tcp        0      0 *:http                  *:*                     LISTEN
tcp        0      0 *:81                    *:*                     LISTEN
tcp        0      0 *:51413                 *:*                     LISTEN
tcp        0      0 localhost:ipp           *:*                     LISTEN
tcp        0      0 Server01-rpi.loca:48087 ns3096483.ip-188-1:9001 ESTABLISHED
tcp        0      0 Server01-rpi.local:5678 portable.local:46416    ESTABLISHED
tcp        0      0 Server01-rpi.local:5678 portable.local:46408    ESTABLISHED
tcp        0      0 Server01-rpi.local:5678 portable.local:46406    ESTABLISHED
tcp        0      0 Server01-rpi.loca:53598 130-254-47-212.re:https ESTABLISHED
tcp        0    208 Server01-rpi.local:5678 bo-18-132-134.ser:48861 ESTABLISHED
tcp6       0      0 [::]:microsoft-ds       [::]:*                  LISTEN
tcp6       0      0 [::]:10443              [::]:*                  LISTEN
tcp6       0      0 [::]:netbios-ssn        [::]:*                  LISTEN
tcp6       0      0 [::]:5678               [::]:*                  LISTEN
tcp6       0      0 [::]:81                 [::]:*                  LISTEN
tcp6       0      0 [::]:51413              [::]:*                  LISTEN
tcp6       0      0 ::1%1994895292:ipp      [::]:*                  LISTEN
udp        0      0 *:33774                 *:*
udp        0      0 *:35421                 *:*
udp        0      0 *:ipp                   *:*
udp        0      0 Server01-rpi.local:ntp  *:*
udp        0      0 localhost:ntp           *:*
udp        0      0 *:ntp                   *:*
udp        0      0 192.168.0.25:netbios-ns *:*
udp        0      0 Server01-rpi:netbios-ns *:*
udp        0      0 *:netbios-ns            *:*
udp        0      0 192.168.0.2:netbios-dgm *:*
udp        0      0 Server01-rp:netbios-dgm *:*
udp        0      0 *:netbios-dgm           *:*
udp        0      0 Server01-rpi.loca:38095 *:*
udp        0      0 *:51413                 *:*
udp        0      0 *:mdns                  *:*
udp        0      0 *:1900                  *:*
udp        0      0 *:1900                  *:*
udp        0      0 *:41371                 *:*
udp6       0      0 fe80::ba27:ebff:fef:ntp [::]:*
udp6       0      0 ::1%1994895292:ntp      [::]:*
udp6       0      0 [::]:ntp                [::]:*
udp6       0      0 [::]:mdns               [::]:*
udp6       0      0 [::]:48014              [::]:*
Active UNIX domain sockets (servers and established)
Proto RefCnt Flags       Type       State         I-Node   Path
unix  11     [ ]         DGRAM                    7171     /dev/log
unix  2      [ ACC ]     STREAM     LISTENING     5717     /var/run/dbus/system_bus_socket
unix  2      [ ACC ]     STREAM     LISTENING     5730     /var/run/sdp
unix  2      [ ACC ]     STREAM     LISTENING     15721    /var/run/cups/cups.sock
unix  2      [ ACC ]     STREAM     LISTENING     5759     /var/run/avahi-daemon/socket
unix  2      [ ACC ]     SEQPACKET  LISTENING     411      /run/udev/control
unix  2      [ ACC ]     STREAM     LISTENING     5789     /var/run/lighttpd/php.socket-0
unix  2      [ ACC ]     STREAM     LISTENING     58813    /var/run/tor/control
unix  2      [ ACC ]     STREAM     LISTENING     97244    /tmp/ssh-Ls3jBT26nn/agent.3967
unix  2      [ ACC ]     STREAM     LISTENING     6622     /var/run/samba/unexpected
unix  2      [ ACC ]     STREAM     LISTENING     6644     /var/run/minissdpd.sock
unix  2      [ ]         DGRAM                    7348
unix  3      [ ]         STREAM     CONNECTED     7377
unix  3      [ ]         DGRAM                    4532
unix  3      [ ]         STREAM     CONNECTED     58808
unix  3      [ ]         STREAM     CONNECTED     51061    /var/run/dbus/system_bus_socket
unix  3      [ ]         STREAM     CONNECTED     7384
unix  3      [ ]         STREAM     CONNECTED     52496
unix  3      [ ]         STREAM     CONNECTED     5728
unix  3      [ ]         STREAM     CONNECTED     46801
unix  3      [ ]         STREAM     CONNECTED     46788
unix  3      [ ]         STREAM     CONNECTED     6654
unix  3      [ ]         STREAM     CONNECTED     725
unix  3      [ ]         STREAM     CONNECTED     843
unix  3      [ ]         STREAM     CONNECTED     6559
unix  3      [ ]         STREAM     CONNECTED     722
unix  2      [ ]         DGRAM                    6530
unix  3      [ ]         STREAM     CONNECTED     5755
unix  2      [ ]         DGRAM                    6668
unix  3      [ ]         STREAM     CONNECTED     6589     /var/run/dbus/system_bus_socket
unix  2      [ ]         DGRAM                    7372
unix  2      [ ]         DGRAM                    96198
unix  3      [ ]         STREAM     CONNECTED     7378     /var/run/dbus/system_bus_socket
unix  3      [ ]         DGRAM                    4531
unix  3      [ ]         STREAM     CONNECTED     58809
unix  3      [ ]         STREAM     CONNECTED     96199
unix  3      [ ]         STREAM     CONNECTED     96200    /var/run/dbus/system_bus_socket
unix  3      [ ]         STREAM     CONNECTED     7385     /var/run/dbus/system_bus_socket
unix  3      [ ]         STREAM     CONNECTED     46802    /var/run/dbus/system_bus_socket
unix  2      [ ]         DGRAM                    5727
unix  3      [ ]         STREAM     CONNECTED     6584     /var/run/dbus/system_bus_socket
unix  2      [ ]         DGRAM                    5753
unix  2      [ ]         DGRAM                    5642
unix  3      [ ]         STREAM     CONNECTED     51641    /var/run/dbus/system_bus_socket
unix  2      [ ]         DGRAM                    6587
unix  3      [ ]         STREAM     CONNECTED     721
unix  3      [ ]         STREAM     CONNECTED     724
unix  3      [ ]         STREAM     CONNECTED     6558
unix  3      [ ]         STREAM     CONNECTED     5756
unix  3      [ ]         STREAM     CONNECTED     5761
unix  3      [ ]         STREAM     CONNECTED     7228     /var/run/dbus/system_bus_socket
unix  3      [ ]         STREAM     CONNECTED     7393     /var/run/dbus/system_bus_socket
Inviato dal mio m2 note utilizzando Tapatalk
Il mio software non ha mai bugs. Include soltanto funzionalità casuali.


Risposta
#7
Se no, meglio ancora dai un
Codice:
nmap -sV localhost
che vedi che software è in ascolto sulla porta che ti interessa

Inviato dal mio m2 note utilizzando Tapatalk
Il mio software non ha mai bugs. Include soltanto funzionalità casuali.


Risposta
#8
@gabriele toselli

ciao gabriele, con questo comando "pi@raspberrypi / $ nmap -sV localhost" ricevo questa risposta "bash: nmap: command not found" invece con "netstat -a" mi da' un mucchio di porte ma non vedo la mia, quindi presumo che motion non sia partito ....con il comando "pi@raspberrypi / $ nmap -sV localhost" risponde "bash: nmap: command not found"
ho provato a dare "pi@raspberrypi / $ start motion" ma mi risponde "bash: start: command not found" per cui probabilmente non e' sulla "root" giusto?

ho provato a cercare "motion" attraverso il gestore file "PCManFM" integrato in raspbian caricato con "noobs" ma non trovo nulla

lo so, sono un po' negato e credo di aver fatto un po' di casino ma mi piacerebbe molto arrivare in fondo a 'sta cosa!

sempre grazie per la disponibilita'

ciao, franco
Risposta
#9
I comandi, parlando del n generale, non sono altro che programmi. Se non c'è, lo puoi installare.
Codice:
sudo apt-get install nmap

Installerà Nmap, e dopo lo potrai usare
Risposta
#10
@gabriele toselli
errata corrige: ho trovato un sacco di "motion" cartella e files chiamati "motion" eseguibile, "motion" documento di testo e "motion" script shell ---- bastava solo aspettare l'uotput Smile dannata fretta ---- con date diverse
tutte le cartelle "motion" hanno data 31/12/15 presumibilmente quando ho fatto l'ultima installazione
i files eseguibili hanno date 19/12/15 316.9 kb e 17/11/12 301.2kb
i files documento hanno date 31/12/15 68 bytes
i files script shell hanno date 12/02/12 2.4 kb
devo lasciarli tutti o e' meglio pulire qualcosa?
mi rimane ancora oscuro come far partire il programma "motion", credo di dover mettermi sulla cartella giusta e poi dare "motion start" ma dov'e' quella giusta?
grazie
-- se non si chiede si rimane ignoranti --

@gabriele toselli

ok: installato nmap e questo e' il risultato da cui deduco che non c'e' nessuna porta 8081 in ascolto e quindi il programma "motion" non e' attivo

pi@raspberrypi / $ nmap -sV localhost

Starting Nmap 6.00 ( http://nmap.org ) at 2016-01-02 11:33 UTC
Nmap scan report for localhost (127.0.0.1)
Host is up (0.0035s latency).
Other addresses for localhost (not scanned): 127.0.0.1
Not shown: 997 closed ports


PORT STATE SERVICE VERSION
22/tcp open ssh OpenSSH 6.0p1 Debian 4+deb7u2 (protocol 2.0)
5901/tcp open vnc VNC (protocol 3.8)
6001/tcp open X11 (access denied)
Service Info: OS: Linux; CPE: cpe:/o:linux:kernel

Service detection performed. Please report any incorrect results at http://nmap.org/submit/ .
Nmap done: 1 IP address (1 host up) scanned in 7.39 seconds

ho provato cosi'

pi@raspberrypi /var/run/motion $ motion start
[1978192760] [NTC] [ALL] conf_load: Processing thread 0 - config file /etc/motion.conf
[1978192760] [NTC] [ALL] motion_startup: Motion mmaltest Started
[1978192760] [NTC] [ALL] motion_startup: Logging to file (/home/pi/motion.log)

e sembra che "motion" sia partito ma se do' questo comando
pi@raspberrypi /var/run/motion $ nmap -sV localhost

Starting Nmap 6.00 ( http://nmap.org ) at 2016-01-02 11:39 UTC
Nmap scan report for localhost (127.0.0.1)
Host is up (0.0020s latency).
Other addresses for localhost (not scanned): 127.0.0.1
Not shown: 997 closed ports
PORT STATE SERVICE VERSION
22/tcp open ssh OpenSSH 6.0p1 Debian 4+deb7u2 (protocol 2.0)
5901/tcp open vnc VNC (protocol 3.8)
6001/tcp open X11 (access denied)
Service Info: OS: Linux; CPE: cpe:/o:linux:kernel

Service detection performed. Please report any incorrect results at http://nmap.org/submit/ .
Nmap done: 1 IP address (1 host up) scanned in 7.28 seconds

la porta 8081 e' ancora chiusa
Risposta
  


Vai al forum:


Navigazione:
Forum con nuovi Post
Forum senza nuovi post
Forum bloccato
Forum Redirect