• Benvenuti su RaspberryItaly!
Benvenuto ospite! Login Login con Facebook Registrati Login with Facebook


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5

[-]
Tags
via ubuntu rpi cavo ethernet connessione netbook

[Problema] connessione netbook ubuntu -RPI via cavo ethernet
#1
Ancora non sono riuscito a collegare netbook ubuntu con RPI (Raspbian) via cavo di rete. Ho seguito la guida e anche altre. Ho impostato ip fissi via cavo di entrambi. Da network manager di ubuntu avvio "connessione via cavo RPI" impostata precedentemente. da ubuntu riesco a fare ping ip di RPI, ma quando avvio ssh pi@indirizzoIPRPI mi risponde "ssh: connect to host 192.168.0.14 port 22: Connection refused". Come posso risolvere? Eppure una volta ha funzionato.

mi sapreste dare una mano?

Grazie

Saluti LaPa
With a little/big help from my friends Rolleyes
Risposta
#2
Ciao, quando condividi la rete eth dal portatile al portatile viene assegnato un ip nella rete da esso creata.
Mi sembra incominci con 10.
Sul raspi devi mettete quell'indirizzo come gateway. L'hai fatto?

Inviato dal mio m2 note utilizzando Tapatalk
Il mio software non ha mai bugs. Include soltanto funzionalità casuali.


Risposta
#3
(15/02/2016, 12:23)GabrieleToselli Ha scritto: Ciao, quando condividi la rete eth dal portatile al portatile viene assegnato un ip nella rete da esso creata.
Mi sembra incominci con 10.
Sul raspi devi mettete quell'indirizzo come gateway. L'hai fatto?

Inviato dal mio m2 note utilizzando Tapatalk
Allora penso che abbia sbagliato:
Io ho assegnato 2 IP statici per i collegamenti via cavo:
RPI (Raspbian) = 192.168.0.14
Netbook (Ubuntu) = 192.168.0.9
1) E' corretto? mi sembra di no
Su Netbook ho impostato come gateway per il collegamento via cavo 192.168.0.1
Su RPI non so qual'è il gateway e se l'ho impostato o come si faccia ad impostarlo.
Eventualmente come devo correggere?
With a little/big help from my friends Rolleyes
Risposta
#4
(15/02/2016, 14:10)LaPa Ha scritto:
(15/02/2016, 12:23)GabrieleToselli Ha scritto: Ciao, quando condividi la rete eth dal portatile al portatile viene assegnato un ip nella rete da esso creata.
Mi sembra incominci con 10.
Sul raspi devi mettete quell'indirizzo come gateway. L'hai fatto?

Inviato dal mio m2 note utilizzando Tapatalk
Allora penso che abbia sbagliato:
Io ho assegnato 2 IP statici per i collegamenti via cavo:
RPI (Raspbian) = 192.168.0.14
Netbook (Ubuntu) = 192.168.0.9
1) E' corretto? mi sembra di no
Su Netbook ho impostato come gateway per il collegamento via cavo 192.168.0.1
Su RPI non so qual'è il gateway e se l'ho impostato o come si faccia ad impostarlo.
Eventualmente come devo correggere?

Allora visto che non ho ricevuto ulteriori suggerimenti provo ad interpretare le parole di Gabriele Toselli: Vado sull'iconcina in alto a destra dello schermo del RPI che mostra la connessione via cavo e cerco d'inserire come gateway l'IP Fisso che ho attribuito al netbook (Ubuntu), che è 192.168.0.9 .
Potreste darmi una conferma.
Grazie
Saluti
LaPa
With a little/big help from my friends Rolleyes
Risposta
#5
no, segui questa procedura.
  1. Collega il cavo ethernet al pc e al raspi
  2. Attacca l'alimentazione al raspi
  3. Assicurati che, cliccando sull'iconcine del wifi del pc venga fuori una roba del genere:
    [Immagine: P60216_152847.jpg]
  4. Sempre da pc, lancia il comando
    hostname -I
  5. Ti verranno visualizzati 2 ip
    [Immagine: Schermata_del_2016_02_16_15_35_47.png]
  6. Il primo è il gateway della rete creata del pc
  7. Il secondo è l'ip assegnato al mio pc dal router.
  8. Sul raspi imposta come gateway il primo..quello che comincia con 10 insomma...
  9. Sempre sul raspi imposta un ip statico tipo 10.42.0.2
Facci sapere!
Il mio software non ha mai bugs. Include soltanto funzionalità casuali.


Risposta
#6
la risposta al comando è la seguente se avvio "connessione via cavo a rpi" che è una connessione che ho fatto, è la seguente:
192.168.0.9 192.168.0.11

nessun 10.42 ...

forse perché ho impostato ip statico di netbook ubuntu per la connessione via cavo che è 192.168.0.9 e ip statico per la connessione del netbook ubuntu per la rete wireless chee è 192.168.0.11.

Ho impostato ip statici anche per rpi = 192.168.0.16 per la wireless e 192.168.0.14 per i collegamenti eth0
With a little/big help from my friends Rolleyes
Risposta
#7
Carissimi, non mi piace lasciare le cose a metà, quindi riprendo l'argomento.
Non sono riuscito a fare il collegamento seguendo la vostra guida, probabilmente ci sono dei passaggi che solo chi ha più esperienza di me sa affrontare.

Come dicevo ho impostato per fare il collegamento (seguendo delle indicazioni trovate in rete) IP statici per il collegamento via cavo per RPI 192.168.0.14, per il netbook 192.168.0.9. Come gateway per entrambi 198.168.0.1 .

Con queste impostazioni, e dopo un po' di smanettamenti che non saprei ripetere, sono riuscito a collegare via cavo RPI e netbook via ssh. Sono riuscito anche a fare il collegamento VNC, funziona bene (anche se la preview del modulo cam non si vede, ma quella è un'altra storia).

So di avere seguito una strada errata, infatti lo strano è che riesco a fare ping da netbook ma non da RPI. poi una volta collegato via cavo non rieco a connettermi con la wireless nè da netbook che da RPI.

Pensate che io debba azzerare tutto e ritentare una strada più lineare di quella percorsa?

Un saluto

Grazie

LaPa
With a little/big help from my friends Rolleyes
Risposta
#8
Prova a azzerare tutto e ripartire. Non appena trovi un problema, seguendo la guida, ti fermi e scrivi qui. Non proseguire a tentativi che poi non sai ripetere, o sarà sempre impossibile aiutarti.
Risposta
#9
Caspita c'ha pensato RPI ad azzerare tutto: non mi parte più Raspbian Sad.
Sposto in altra discussione e poi eventualmente quando avrò ripristinato riprendo questo argomento

Grazie

Ciao

LaPa
With a little/big help from my friends Rolleyes
Risposta
#10
allora, ho ripristinato tutto. Ho assegnato ip fissi su RPI sia per la wireless che per collegamenti cona cavetto ad internet.

Ho seguito la vostra guida http://www.raspberryitaly.com/colleth/

su ubuntu ho creato la connessione condividi eth, impostando la connessione. ho collegato il raspberry al computer ubuntu assicurandomi che su quest'ultimo sia utilizzata la connessione "condividi eth",su informazioni sulla connessione l'indirizzo è 10.42.0.1, me lo sono appuntato ma su rpi non so come andare avanti visto che non vedo l'iconcine della connessione via cavo. Forse perchè avevo già precedentemente impostato una ip fisso per le connessioni eth0?

Comunque se passo con il mouse su l'icona delle connessioni su RPI mi dice che l'indirizzo della connessione via cavo è 10.42.0.53. se da terminale di ubuntu scrivo ssh pi@10.42.53 effettivamente mi collego al RPI.

Se RPI è collegato via cavo con computer, anche se via wireless sembrerebbe collegato non va su web.

Mi potreste indicare come continuare?

Come faccio a mettere l'indirizzo ip 10.42.0.1 "......come gateway sul raspi" come indicate nella vostra guida?
With a little/big help from my friends Rolleyes
Risposta
  


Vai al forum:


Navigazione:
Forum con nuovi Post
Forum senza nuovi post
Forum bloccato
Forum Redirect