• Benvenuti su RaspberryItaly!
Benvenuto ospite! Login Login con Facebook Registrati Login with Facebook


Tags
Author: incrys - Replies: 10 - Views: 3637
Sensore Dallas DS18B20
Buongiorno a tutti,
ho comprato da poco il quarto raspberry e per una questione di continuità ho scelto di prendere l'unico modello che ancora non avevo un B+.
Bene, questo benedettissimo figliolo è così simpatico da non riconoscermi in nessun modo un sensore temperatura dallas DS18B20.
Ho connesso tramite breadboard l'alimentazione, GPIO 4# e GND. Ho anche messo la resistenza da 4,7k, misurato accuratamente che ci sia continuità su tutti i pin tramite tester e misurato la tensione. Tutto sem
Author: Mitja - Replies: 2 - Views: 2065
rilevamento temperatura DS18B20 tramite web
Ciao a tutti! Sono nuovo nel mondo di raspberry e volevo iniziare con un progetto semplice semplice, che però, non ne vengo a capo Rolleyes

Il progetto consiste nel rilevare la temperatura da DS18B20 e raffigurare i dati su un sito internet.

Qui le fasi del progetto:
1. Collegare il DS18B20 al raspberry pi2.
2. Far riconoscere al raspberry il sensore.
3. Rilevare la temperatura dal sensore DS18B20 sul terminale.
4. Creare un server MYSQL.
5. Salvare i dati della temperatura su serv
Author: LaPa - Replies: 16 - Views: 6801
Sensore temperatura ds18B20 display e Thingspeak
Salve,
ho un raspberry pi 2 model b con Rasbian, un sensore di temperatura digitale DS18B20, un display 16X2, vorrei leggere la temperatura sul display. Sapreste indicarmi lo schema da seguire su breadbord, il software per fare funzionare il tutto?

C'è un tutorial per tutto ciò?

Grazie

LaPa
Author: Francis Mattias Drake - Replies: 1 - Views: 1176
Sensore temperatura DS18B20
Ho acquistato questo sensore digitale un dht11 (dallas DS18B20).
ho seguito la guida dal sito https://learn.adafruit.com/adafruits-ras...g/software
ho problemi con la parte software.
quando eseguo il file thermometer.py mi esce il seguente errore:
SyntaxError: Non-ASCII character 'xc2' in file 'thermometer.py on line 4, but no encoding declared; see https://www.python.org/dev/peps/pep-0263/
ho aggiunto le 2 righema non cambia nulla


[code]#!/us
Author: rdie77 - Replies: 10 - Views: 1560
Sensore DS18B20 che segna sempre 85
Salve a tutti
Ieri ho spento il mio raspberry con il sensore in oggetto, e l'ho riacceso la sera.
Da ieri sera il sensore mi segna sempre 85
Quale può essere il problema?

Grazie ancora

Ho provato anche a mettere il sensore dht22 sulla porta dov'era il DS18B20, e la porta funziona...
Author: Casagrande - Replies: 8 - Views: 2034
scratch e ds18b20
Buona sera sono nuovo del forum, avrei bisogno di una mano:
 volevo misurare la temperatura con una sonda ds18b20 però quando invio il comando gettemp mi escono delle variabili tipo: ora, minuti, ora completa, però se invio il comando: gettempcpu mi esce la temperatura della CPU, riesce a darmi una mano? Uso il programma scratch gpio 8
Author: paolo attanasio - Replies: 15 - Views: 3420
tempi lunghi x lettura temperatura con ds18b20 in python
Buonasera a tutti,
sono passato da poco da arduino a Rasp per un progetto di automazione luci-temperatura-co2-etc per l'acquario.
Per acquisire il dato corrente di temperatura dell'acqua uso una sonda DS18b20 collegata al gpio4 (pin7), usando la libreria w1thermsensor. Funziona tutto, ma il tempo impiegato dal sistema, ogni volta che viene aggiornata la tempertura corrente, è di ben 880 ms. E' normale? O sbaglio io qualcosa?
grazie a tutti
paolo
Author: albertopolino - Replies: 2 - Views: 1173
ds18b20 FATAL: Module w1–gpio not found in directory /lib/modules/4.19.57
buongiorno.
Ho in funzione da tempo tre sonde ds18b20 connesse a GPIO4. Questa mattina, dopo un reboot, le sonde hanno smesso di funzionare e sono sparite dalla directory sostitute da valori tipo 00-080000000000. se digito sudo modprobe w1–gpio mi compare il messaggio: modprobe: FATAL: Module w1–gpio not found in directory /lib/modules/4.19.57+. Non ho cambiato nulla a livello HW. Non so cosa pensare. Qualche idea? Grazie
Author: albertopolino - Replies: 4 - Views: 1111
DS18B20 cavi troppo lunghi
Buonasera,
ho tre DS18B20 collegati one wire per rilevare tre differenti temperature. i primi due funzionano senza problemi mentre il terzo, distante una decina di metri dal Raspberry, mostra delle instabilità abbastanza curiose. Funziona per giorni, anche per mesi senza problemi e, all'improvviso, diventa del tutto ingovernabile. Ho letto tutti i thread che ho trovato e seguito i vari suggerimenti per cui ho utilizzato un cavo di rete cat 6, ho ridotto la resistenza di pullup, sostituito senso
Author: albertopolino - Replies: 52 - Views: 7382
Lo strano caso del DS18B20
Apro un nuovo topic riguardo un problema già segnalato perché mi trovo di fronte ad una anomalia che mi sembra abbastanza singolare e da cui non riesco a venire a capo. Tre DS18B20 collegati in maniera canonica con positivo, negativo e dati con relativa resistenza. Due funzionano senza problemi. Il terzo, con cavo di una decina di metri, funziona per un po' poi si blocca. La cosa strana è che se stacco quest'ultimo per qualche ora, riprende a funzionare per un po'. Cosa può succedere? 
1) si ac
Forum con nuovi Post
Forum senza nuovi post
Forum bloccato
Forum Redirect